Windows Multipoint Server Issue SRCShell.exe (WMS 2011) WMSShell.exe (WMS 2012)

The problem:

Mulitpoint boots up and “auto-logs-in” as WMSShell user however the stations do not initiate a session and the blank default windows desktop is viewable. Its like its stuck in maintenance mode.

The fix:

As it turns out Multipoint server 2011 or 2012 autologs the local user WMSShell in and then autostarts the multipoint interface which is located at: C:\Program Files\Windows MultiPoint Server\SRCShell.exe. (WMS 2011) or C:\Program Files\Windows MultiPoint Server\WMSShell.exe (WMS2012)

The C:\Program Files\Windows MultiPoint Server\SRCShell.exe is the missing part. if you run the EXE (locally) it will start the familiar Multipoint Login Screen.

ok fixed right.. no….not quite…

To make this work after a reboot a little more work is needed. The problem is that the C:\Program Files\Windows MultiPoint Server\SRCShell.exe is called from the WMSShell local user profile. To edit this you must remote into the system as another user and log the WMSShell user off using task manager / users / logoff, then use regedit to open the NTUser.dat file for the WMSShell users profile located in c:\users\WMSShell\NTUser.dat

nt

  1. Open regedit.exe
  2. make sure HKEY_LOCAL_MACHINE is selected on the left panel
  3. click File -> Load Hive in the main menu
  4. open ntuser.dat file in common dialog
  5. specify some temporary name, like USER1
  6. There should be a string key named Shell with the path to the SRCShell.exe however it dissapeered on mine hence the problem so Add a new String Key to HKEY_LOCAL_MACHINE\USER1\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon\ called Shell with the path to C:\Program Files\Windows MultiPoint Server\WMSShell.exeshell
  7. Make sure HKEY_LOCAL_MACHINE\USER1 is selected on the left panel and then unload hive from main menu
  8. reboot.

Fixed.

If anyone knows the reson why this disapeers let me know!!!!